Jump to content

SUBIECTE NOI
« 1 / 5 »
RSS
Cum pot bloca primirea mesajelor ?

Anonimitate, Darkweb, TOR

Legat 2 difuzoare de bass

pot activa așa o extraop5...
 Întrebare intrebatoare: ce se inta...

Locuri din Romania aflate pe o gr...

Propuneri destinatii vacanta- bug...

o problema mai ciudata ( fuji xf1)
 poti fii medic?

Ioan Gyuri Pascu

Chrome deschide 8 procese?

av pe tableta
 Sfaturi achiziție telefon de...

CPU usage 30%

Caut sistem audio

Achizitie motoferastrau (drujba)
 
Forumul Softpedia folosește "cookies" pentru a oferi utilizatorilor o experiență completă. Vezi detalii sau închide mesaj (x)

[Rezolvat] Lipsa /dev/video

- - - - -
  • Please log in to reply
10 replies to this topic

#1
bogdan1978buc

bogdan1978buc

    Active Member

  • Grup: Members
  • Posts: 1,409
  • Înscris: 07.05.2003
  • ID membru: 3,637
Salut,

Folosesc de ceva timp un raspi la care am o camera web pe usb si care a mers fara probleme... pana la ultimul update, upgrade.
In momentul de fata:
1) nu mai am /dev/video
2) lsusb: apare Bus 001 Device 004: ID 1908:2310 GEMBIRD
3) lsmod: nimic
4) dmesg -H|tail
[  +1.246778] uart-pl011 3f201000.uart: no DMA platform data
[  +0.111530] Adding 102396k swap on /var/swap.  Priority:-1 extents:2 across:217084k SSFS
[  +0.432699] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[  +0.796694] random: nonblocking pool is initialized
[  +0.863221] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
[May16 22:23] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[  +0.181007] usb 1-1.4: New USB device found, idVendor=1908, idProduct=2310
[  +0.000024] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  +0.000013] usb 1-1.4: Product: USB2.0 PC CAMERA
[  +0.000013] usb 1-1.4: Manufacturer: Generic

Ce as putea face? Folosesc:
uname -a
Linux raspberrypi 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux

Multumesc!

#2
shogun1

shogun1

    Cranky old n00b ☯

  • Grup: Moderators
  • Posts: 5,351
  • Înscris: 31.01.2009
  • ID membru: 414,359
  • Locație: $HOME
Salut, despre Raspberrypi s-a mai discutat pe ”Generalități”, am mutat topicul tău aici.
O zi bună!

#3
bogdan1978buc

bogdan1978buc

    Active Member

  • Grup: Members
  • Posts: 1,409
  • Înscris: 07.05.2003
  • ID membru: 3,637
Conform celor de mai sus am setat motion sa utilizeze "videodevice /dev/bus/usb/001/004" sperand ca o sa mearga in locul "videodevice /dev/video0" dar se pare ca nu ma ajuta.
Chiar nu stiu ce s-a intamplat dupa ultimul upgrade iar nivelul meu de cunostinte in lumea Linux este de novice asa ca putin ajutor mi-ar prinde bine.

#4
bogdan1978buc

bogdan1978buc

    Active Member

  • Grup: Members
  • Posts: 1,409
  • Înscris: 07.05.2003
  • ID membru: 3,637
Am conectat 3 webcamuri dar degeaba:
lsusb
Bus 001 Device 006: ID 1908:2310 GEMBIRD
Bus 001 Device 005: ID 1908:2310 GEMBIRD
Bus 001 Device 004: ID 0471:0333 Philips (or NXP) SPC 620NC PC Camera

Cum fac sa "montez" o camera care inainte se incarca singura?

#5
shogun1

shogun1

    Cranky old n00b ☯

  • Grup: Moderators
  • Posts: 5,351
  • Înscris: 31.01.2009
  • ID membru: 414,359
  • Locație: $HOME
Nu le am cu raspberrypi, nu știu ce fel de Linux are pe el. Hai să-mi dau cu presupusul.
Ce zice:
v4l2-ctl --list-devices

E necesar să ai instalat v4l-utils. Dar:
ls -ltrh /dev/video*



#6
bogdan1978buc

bogdan1978buc

    Active Member

  • Grup: Members
  • Posts: 1,409
  • Înscris: 07.05.2003
  • ID membru: 3,637
v4l2-ctl --list-devices
Failed to open /dev/video0: No such file or directory

ls -ltrh /dev/video*
ls: cannot access /dev/video*: No such file or directory

Asta este problema ca nu mai am nici un video in /dev/
Distributia se numeste raspbian, bazat pe Debian.

#7
shogun1

shogun1

    Cranky old n00b ☯

  • Grup: Moderators
  • Posts: 5,351
  • Înscris: 31.01.2009
  • ID membru: 414,359
  • Locație: $HOME
Driverul v4l2 îți creează /dev/video0. Cică asta ar rezolva (https://www.raspberr...=68247&p=498140):
sudo rpi-update
sudo modprobe bcm2835-v4l2

sudo rpi-update   # to make sure the v4L2 drive is available.
sudo modprobe bcm2835-v4l2   # to load it and create /dev/video0

LE: tot despre subiect: https://www.raspberr...hp?f=43&t=62364

Edited by shogun1, 20 May 2017 - 19:43.


#8
bogdan1978buc

bogdan1978buc

    Active Member

  • Grup: Members
  • Posts: 1,409
  • Înscris: 07.05.2003
  • ID membru: 3,637
S-a rezolvat cu sudo rpi-update a aparut din nou /dev/video
rpi-update nu-l aveam, l-am descarcat si apoi l-am rulat ajung la:

uname -a
Linux raspberrypi 4.9.28-v7+ #999 SMP Tue May 16 14:03:19 BST 2017 armv7l GNU/Linux

Ceea ce reprezinta un pas major fata de primul post:

uname -a
Linux raspberrypi 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux

Multumesc!!!

EDIT: am o mica problema, spatiul disponibil. Trebuie sa-l eliberez pentru ca mai am vreo 100M, probabil s-a pastrat pe sd ceva temporar si vad ca nu ma ajuta autoclean / autoremove

Edited by bogdan1978buc, 20 May 2017 - 20:26.


#9
n0n1

n0n1

    Junior

  • Grup: Members
  • Posts: 353
  • Înscris: 30.06.2008
  • ID membru: 343,154
  • Locație: Spantov, Calarasi
dpkg --list | grep linux-image
sudo apt-get purge linux-image-x.x.x.x-generic
sudo update-grub2

#10
shogun1

shogun1

    Cranky old n00b ☯

  • Grup: Moderators
  • Posts: 5,351
  • Înscris: 31.01.2009
  • ID membru: 414,359
  • Locație: $HOME
Mulțumesc pentru feedback!

#11
bogdan1978buc

bogdan1978buc

    Active Member

  • Grup: Members
  • Posts: 1,409
  • Înscris: 07.05.2003
  • ID membru: 3,637
@n0n1: nu ma ajuta

"
dpkg --list | grep linux-image
sudo apt-get purge linux-image-x.x.x.x-generic
sudo update-grub2
"
In schimb:
ls /lib/modules/
4.9.24+  4.9.24-v7+  4.9.28+  4.9.28-v7+  4.9.29+  4.9.29-v7+  4.9.30+  4.9.30-v7+
As putea sa-i dau direct sudo rm -r si sa incep sa adaug directoarele mai putin ultima versiune?
Am vazut ca exista si un /boot cat si un /boot.bak. Pe cel din urma l-am sters asa ca voi vedea la un reboot daca am probleme Posted Image

@shogun1: n-ai pentru ce Posted Image M-ai salvat big time!

Edit: vad ca merge cu sudo rm -r 4.9.24+ , etc.

Edited by bogdan1978buc, 01 June 2017 - 22:25.


Anunturi


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users